آغاز سرویس دهی از طریق گفتگوی آنلاین تلگرام ، از این پی سی وب در تلگرام نیز در کنار شما خواهد بود و خبر های خوش دیگر ...

شروع یک گفتگوی جدید

| تجربه لذت شیرین پشتیبانی و کیفیت واقعی

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین

صفحه اصلی آموزش باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین

تاریخ انتشار : 12 ماه پیش : ۲۸ آذر ۱۳۹۵ بازدید : 11891

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین – هشدار جدی به کاربران ویبولتین !

سلام دوستان ، امیدواریم  که حالتون خوب باشه ، به شب یلدا نزدیک هستیم و پیشاپیش برایتان یلدای خوبی رو آرزومندیم ،

در طی این چند روز شاهد مورد نفوذ قرار گرفتن تعدادی از انجمن های ویبولتین بودیم که همه و همه به خاطر عدم توجه به هشدار های امنیتی و سهل انگاری بوده است . هیچ وقت هک شدن و مورد نفوذ قرار گرفتن انجمن ها و وب سایت های کاربران برای ما خوشایند نبوده است و همیشه از مورد نفوذ قرارگرفتن انجمن ها و وب سایت های کاربران ایرانی ابراز ناراحتی کرده ایم . در طی این چند روز شاهد رخداد این اتفاقات بوده ایم که برایمان به شدن ناراحت کننده بود .

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین

در زیر به معرفی برخی از این اتفاقات و دلایل آنها را بررسی خواهیم کرد :

برخی از این اتفاقات :

  • مورد نفوذ قرار گرفتن هزاران انجمن ویبولتین به خاطر ضعف های امنیتی پلاگین وی بی سئو .
  • مورد نفوذ قرار گرفتن تعداد بالایی از انجمن های ویبولتین به دلیل عدم بروز رسانی به موقع ویبولتین
  • مورد نفوذ قرار گرفتن تعداد بالایی از انجمن ها عدم بروز رسانی به موقع پلاگین ها
  • مورد نفوذ قرار گرفتن تعداد بالایی از انجمن ها به دلیل عدم استفاده از پچ  های امنیتی
  • مورد نفوذ قرار گرفتن تعداد بالایی از انجمن ها به دلیل عدم توجه به نکات امنیتی
  • مورد نقوذ قرار گرفتن انجمن های بسیاری به خاطر عدم توجه به هشدار های امنیتی
  • مورد نفوذ قرار گرفتن انجمن ها به خاطر مشکلات امنیتی SQL injectuin
  • و…

منظور از مورد نفوذ قرار گرفتن در موارد بالا ، هر گونه اسیب و ایجاد اختلال در انجمن می باشد .

به عنوان یکی از بزرگترین و قدیمی ترین ارائه دهندگان خدمات پشتیبانی ویبولتین در ایران ،

وظیفه خودمان می دانیم ، که در خصوص مسائل امنیتی به کاربران ویبولتین در ایران بیشتر توضیه هایی رو داشته باشیم .

و بیشتر اطلاع رسانی نماییم که کاربران کمتر با چنین مسائلی روبرو باشند .

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین – بخش اول :

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین – بخش اول :

دلیل این که این عنوان رو برای این پست انتخاب کردم ، اطلاع رسانی هست که در تمامی نسخه های مختلف ویبولتین باگ های امنیتی وجود دارد ،

و اگر نکات امنیتی ساده و ضروری هر انجمن رو رعایت نکنید ، با مشکلات مختلفی روبرو خواهند بود .

در ویبولتین شما این اجازه رو دارید که از هر نسخه ای که میخواهید استفاده کنید ،

این ایتم خوبی هایی رو داره که اگر از نسخه خاصی خوشتون میاد از همون نسخه استفاده کنید

ولی خوب به شرطی استفاده از یک نسخه خاص در طولانی مدت پیشنهاد میشه که دانش امنیتی قوی رو داشته باشید .

دیدم مثلا در نسخه 4 ویبولتین :

هنوز عده ای از نسخه های 4.1 استفاده میکنند یا عده ای هنوز درگیر نسخه 4.2 هستند ، با وجود این که اخرین نسخه ویبولتین 4.2.3 پچ لول 2 هست .

ایرادی نداره از نسخه های قدیمی استفاده کنید :

به شرط این که به تمامی مسائل امنیتی و برنامه نویسی مسلط باشید و بتوانید خودتون مشکلات امنیتی و برنامه نویسی انها را رفع کنید .

در غیر این صورت بهترین راهکار ، استفاده از اخرین نسخه اون ورژن هست .

مثلا در خصوص ویبولتین 4 :

بهترین نسخه فعلی آن 4.2.3 پچ لول 2 می باشد ،

که برای دانلود ویبولتین 4.2.3 پچ لول 2 میتوانید به لینک (دانلود آخرین نسخه ویبولتین)

و یا برای دانلود این نسخه میتوانید به لینک (دانلود ویبولتین 4.2.3) مراجعه فرمایید .

این کار باعث میشود از خیلی از مشکلات امنیتی سطح دوم در امان باشید .

بخش دوم – باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین :

در این بخش و بخش های بعدی قصد داریم برای این که در حال حاظر از مشکلات امنیتی در امان باشید ، توضیحه هایی رو به شما بکنم :

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین

سال ها بود که کاربران برای سئو و یا سئو سایت ویبولتین خود از از وی بی سئو استفاده میکردند ،

تا زمانی که این پلاگین پشتیبانی داشت خوب بود .

ولی بعد از این که دیگر هیچ گونه پشتیبانی به کاربران از طریق این پلاگین ارائه نشد ،

مشکلات و ضعف های ان روز به روز به چشم آمد

و فرصت برای نفوذگران و هکر ها برای نفوذ آسان به ویبولتین اسان شد و آن چیزی که نباید اتفاق می افتاد اتفاق افتاد :

بعد از این مشکلات ما به تمامی کاربران ویبولتین پیشنهادات زیر رو داشتیم :

1) وی بی سئو خودتون رو حذف کنید . و به جای آن دی بی سئو نصب کنید .

2) اطلاعات وی بی سئو خودتون رو به دی بی سئو منتقل کنید و دی بی سئو خودتون رو به صورت کامل حذف کنید .

3) اگر میخواهید برای سئو ویبولتین پلاگینی نصب کنید ، دیگر وی بی سئو نصب نکنید و به جای آن دی بی سئو نصب کنید.

متاسفانه عده همچنان به این توصیه ها عمل نکرده اند و شاهد مورد نفوذ قرار گرفتن انجمن هایشان هستیم .

حتما پیشنهاد میکنم اگر تا به امروز موارد فوق رو انجان نداده اید ، هم اکنون مسائل فوق رو رعایت کنید .

با رعایت همین نکات ساده از یکی از بزرگترین مشکلات امنیتی ویبولتین در امان خواهید بود .

نکته : برای دانلود دی بی سئو میتوانید به لینک (دانلود دی بی سئو) مراجعه نمایید .

بخش سوم – بروز رسانی پلاگین ها :

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین – بخش سوم :

دنیای وب دائم در حال تغییرات هست و بسیاری از پلاگین ها دائم در حال بروز رسانی هستند .

وقتی یک پلاگین ویبولتین بروز رسانی میشود :

  • یا به ان امکانات جدید اضافه میشود
  • یا مشکلات مختلف آن نظیر مشکلات امنیتی رفع میگردد .

پس خواه ، نخواه وقتی به صورت منظم ، بروز رسانی های یک پلاگین رو انجام میدهید از مشکلات امنیتی دور خواهید بود .

اما عده ای اصلا عادت به بروز رسانی پلاگین ها ندارند و شاید سالی یکبار هم به این که پلاگین قدیمی شده و یا بروز هست توجه نمیکنند .

در این صورت همین مسئله ساده برایشان تبدیل به بحران میشود .

بروز رسانی سالانه پلاگین ها از نظر وقتی حداکثر 2 – 3 ساعت وقت شما رو خواهد گرفت .

و یا اگر یک سرویس پشتیبانی سایت در این خصوص سالی یک بار تهیه کنید کمتر از 150.000 تومان هزینه خواهد داشت .

اما اگر توجه نکنید ، چه اتفاقی خواهد افتاده :

وقتی وب سایت شما مورد نفوذ قرار بگیرد :

همین 2 ساعت به چندین روز زمان تبدیل میشه

و باید چندین روزتون رو به رفع این مشکلات اختصاص دهید .

یا اگر بخواهید به فرد یا مجموعه واگذار کنید ، چندین برابر هزینه خواهد داشت .

و مهم تر از همه چیز در مدتی که مشکلات دارید ، کاربران خود را نیز از دست می دهید و اعتبار شما از بین می رود .

حال به نظر شما ارزش ندارد که در سال حداقل یک بار هزینه کنید و یا زمان بگذارید برای این موضوع ؟

بخش چهارم – نصب پچ های امنیتی :

در این بخش از مقاله (باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین) به موضوع پج های امنیتی خواهیم پرداخت :

پچ امنیتی یا پچ لول چیست ؟

پج امنیتی یا پچ لول معمولا به نسخه های بهتر شده نسخه قبلی می گویند .

مثلا ویبولتین 4.2.3 پچ لول 2 یعنی ویبولتین 4.2.3 ای که بهتر از نسخه اولیه می باشد .

در این نسخه مشکلات و مسائل امنیتی نسخه قبل رفع شده است .

مشکل بعدی که در بالا اشاره کردیم :

  • مورد نفوذ قرار گرفتن تعداد بالایی از انجمن ها به دلیل عدم استفاده از پچ  های امنیتی

دقیقا به خاطر عدم توجه به همین مبحث هست .

لازم هست که حداقل هر 6 ماه یکبار در صورتی که نسخه جدیدی منتشر شده است :

یا پچ لول مربوطه را نصب نمایید و یا نسخه جدید را نصب و راه اندازی نمایید .

عده به این مسائل هم هیچ گونه توجی ندارند !

و در نیحه با همین مسائل امنیتی که رفع نشده است مورد نفوذ واقع میشوند .

با توجه به همین نکته ساد میتوانید مشکلات امنیتی این بخش نیز در امان باشید .

نکته : جدیدترین بروز رسانی ها و پچ ها در پی سی وب از طریق پست (دانلود ویبولتین) اطلاع رسانی میشود .

و شما همواره میتوایند با چک کردن این پست ، از جدیدترین بروز رسانی ها ، استفاده نمایید .

بخش پنجم – عدم رعایت نکات امنیتی اولیه :

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین – بخش پنجم :

بسیاری از وبمستران از مقوله امنیت به کلی دور هستند و واژه نکات امنیتی پایه برایشان مفهومی ندارد !

ولی به عنوان یک مدیر انجمن ، هر مدیری لازم هست که با یکسری نکات امنیتی اشنایی داشته باشد .

در خصوص این میتوانید با سرچ کردن به این نکات دسترسی داشته باشید .

در زیر به برخی از این نکات امنیتی اولیه اشاره میکنم :

  • از هاست ایمن و معتبر استفاده کنید .
  • پیغام های خطا را جدی بگرید .
  • استفاده از رمز عبور مناسب را فراموش نکنید.
  • از پلاگین ها و ماژول های معتبر استفاده کنید .
  • مشخصات و پسورد های سایتتان را در اختیار هر فردی قرار ندید .
  • اعتبار سنجی در قسمت آپلود فایل
  • اعمال محدودیت برای ورود به مدیریت سایت
  • محدود سازی ای پی کاربران برای دسترسی به ابزار های مدیریت
  • تهیه نسخه پشتیبان و بکاپ گیری منظم
  • و…

لیست های کاملتر در این خصوص را میتوانید با سرچ در گوگل به دست بیاورید .

بخش ششم – به هشدار های امنیتی بیشتر توجه کنید :

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین – بخش پنجم :

مطئنا افرادی که در حوزه امنیت ، هشدار هایی رو به کاربران میدهند این هشدار ها برای خودشان نیست

چرا که خودشان کاملا به این مسائل مسلط هستند و نیازی به بازگو کردند ندارند .

متاسفانه با وجود این که بارها به بسیاری از کاربران هشدار هایی رو در این خصوص داده ایم باز هم شاهد

هستیم که به خاطر مسائلی همچون تنبلی ، کوتاهی و… به این نکات توجه نشده است . بارها در وب سایت های مختلف تذکرات و هشدار های مختلف برای استفاده از پسورد های ایمن داده شده است . ولی با این حال باز شاهد هستیم که مدیری برای راحتی خود از پسورد هایی همچون : 12345 – تاریخ تول : 1370 – سال : 1395 ، یا شماره تماس های خودش استفاده میکند .

سالیانه امار بسیار بالایی از نفوذ ها به سایت ها به خاطر همین پسورد های ساده صورت میگرد .

میزان اسیبی که نفوذ از این طریق وارد میکند به مراتب بیشتر از ان است که وب سایت شما یک حفره امنیتی داشته باشد ، این که وب سایت شما حفره امنیتی خاصی داشته باشد ، گاها باعث میشود ، فقط همان بخش با آسیب مواجه شود ، اما وقتی یک نفوذگر به پسورد شما دسترسی داشته باشد ، درصدد خسارت به مراتب بیشتر از نفوذ از طریق یک حفره امنیتی هست .

این پست برای شما کاربران گرامی VBulletin فقط تهیه شده است .

و توجه به همین نکات میتوانید از بسیاری از مشکلات مربوط به :

  • مورد نقوذ قرار گرفتن انجمن های بسیاری به خاطر عدم توجه به هشدار های امنیتی

جلوگیری کند . و شما را از مسائل و مشکلات این بخش در امان نگه دارد .

بخش هفتم – مشکلات امنیتی SQL injectuin :

بعضا در برخی از نسخه ها مشاهده میشود که مشکلات امنیتی وجود دارد .

که تا رفع آن در نسخه های بعدی باید توسط آموزش های موجود در اینترنت آنها را رفع کنید .

مثلا اخیرا متوجه شده ایم ، که حتی در نسخه 4.2.3 پچ لول 2 هم یک باگ امنیتی خطرناک وجود دارد .

این باگ امنیتی خطرناک از نوع SQl Injection می باشد .

که در پلاگین Froum Runner وجود دارد ، و در ادامه روش رفع ان را خواهیم گفت .

برای رفع این مشکل پلاگین from runner را غیرفعال و بعد حذف نمایید.

همچنین در محل نحل انجمن تون پوشه forumrunner را به یک نام ناشناس تغییر نام دهید .

موقتا با این راه حل میتوانید این مشکل را رفع کنید .

باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین – توصیه ها و پیشنهادات :

در نهایت به عنوان آخرین توصیه و پیشنهادات :

به شما توضیه میکنم : حداقل سالی یکبار وب سایت خود را بروز رسانی کنید .

به شما توصیه میکنم : حداقل سالی یکبار از یک متخصص بخواهید وب سایت شما را آنالیز کنید .

برای تامین امنیت ویبولتین ، مقالات امنیت رو همیشه دنبال کنید .

به شما پیشنهاد میکنم : حداقل هر 3 ماه یکبار پسورد های خودتون رو تغییر بدید .

به شما پیشنهاد میکنم : مشخصات وب سایت خودتون رو کمتر در اختیار دیگران قرار بدید .

امیدواریم از این مقاله (باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین)  لذت کافی رو برده باشید . تا مقالاتی دیگر برای شما بهترین ها رو آرزومندم …

باتشکر / تیم تولید محتوا پی سی وب

لینک کوتاه مطلب : https://www.p30web.org/?p=7560

دیدگاه کاربران :

  • جهت تبادل نظر و گفتگو درباره باگ های امنیتی خطرناک در اکثر نسخه های ویبولتین : میتوانید به انجمن پشتیبانی پی سی وب مراجعه نمایید.
  • آدرس انجمن تخصصی پی سی وب : forum.p30web.org
  • دیدگاه ارسال شده توسط شما ، پس از تایید توسط مدیران سایت منتشر خواهد شد.
  • دیدگاهی که به غیر از زبان فارسی یا غیر مرتبط با محصول باشد منتشر نخواهد شد.


گروه طراحی و برنامه نویسی پی سی وب ، طراحی سایت ، پشتیبانی سایت ، سئو و بهنیه سازی


تیم طراحی و برنامه نویسی پی سی وب بزرگترین و قدیمی ترین مجموعه اینترنتی ارائه دهنده خدمات پشتیبانی سایت و طراحی سایت در کشور ایران ، با بیش از 7 سال سابقه درخشان در عرصه طراحی و برنامه نویسی وب با گستره ای از خدمات گوناگون برای کاربران خود « لذت شیرین پشتیبانی واقعی» راتداعی می کند ، «ضمانت بهترین قیمت» ، «مشتری محوری» ، «پشتیبانی واقعی» سه اصل اولیه ای است که پی سی وب از نخستین روز های تاسیس تا به امروز سعی کرده به آن پایبند باشد. شرکت اینترنتی خدمات وب پی سی وب فعالیت خود را از سال 1388 آغاز نموده است و تا به امروز به فعالیت خود ادامه میدهد ، پی سی وب درحال حاظر در کلیه عرصه های طراحی سایت ، پشتیبانی سایت (پشتیبانی انواع اسکریپت های سایت ساز (وردپرس ، جوملا ، دروپال)، انجمن ساز (ویبولتین ، زنفورو ، مای بی بی)، فروشگاه ساز (ووکامرس ، مجنتو ، پرستاشاپ)، آپلود سنتر (کلیجا ، میهالیسم) )، خدمات گرافیکی ، سئو و بهینه سازی سایت ، تبلیغات اینترنتی و ... با قدرت فعالیت دارد .